You all need to update your iPhones and Macs, like right away

2 months ago 110
apple iphone 15 cameras close

Ryan Haines / Android Authority

TL;DR

Apple has released iOS 17.1.2, iPadOS 17.1.2, and macOS Sonoma 14.1.2 to iPhones, iPads, and Macs, respectively. These updates contain fixes for two critical WebKit vulnerabilities actively exploited on older software versions.

iOS 17 has been out for a while, and users largely love the new update. Features like Contact Posters, NameDrop, and StandBy delight everyone; there’s enough good reason to be on the latest update. Not every iOS update brings major features, but these updates are equally important. Apple is now rolling out iOS 17.1.2, iPadOS 17.1.2, and macOS Sonoma 14.1.2 to iPhones, iPads, and Macs, respectively, and you should update to these new versions right away as they contain critical security fixes.

The updates across the three platforms include the same fixes for critical security issues. More specifically, Apple’s support document mentions that the update fixes two WebKit vulnerabilities that have been actively exploited by bad actors on previous versions of iOS (before iOS 16.7.1). WebKit is the engine that powers web components on Apple devices, including Safari, other browsers, and even the App Store.

These two vulnerabilities are CVE-2023-42916 and CVE-2023-42917. The first allowed hackers to obtain sensitive information, while the second allowed them to run malicious code. Considering the wide use of WebKit on Apple devices and that these exploits may have been used in the wild (though Apple provides no further details on their use), it is important for all users to update to the latest iOS, iPadOS, and macOS versions.

The newest update will be arriving on your devices very soon. You can manually check for the update by going to Settings > General > Software Update on your iPhone and iPad and by going to the Apple menu > System Settings > General > Software Update on your Mac devices.

Google’s Threat Analysis Group is credited with finding the vulnerability. The same group also found a serious vulnerability in Google Chrome, which was disclosed about two days ago. If you haven’t already, please ensure your Google Chrome is up-to-date across all platforms. You need to be on Chrome version 119.0.6045.199 for Mac and Linux, version 119.0.6045.200 for Windows, version 119.0.6045.193 for Android, and version 120.0.6099.50 for iOS.

Read Entire Article